// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)pow(\([^)]+),2\)").unwrap();
let string = "pow(alpha,2) + pow(beta,2)
(3*pow(betaR_red,2))
2/pow(gammaBlue,3))
-pow(epsilon_gamma,2)+5";
let substitution = "square\\1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}