using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"pow(\([^)]+),2\)";
string substitution = @"square\1)";
string input = @"pow(alpha,2) + pow(beta,2)
(3*pow(betaR_red,2))
2/pow(gammaBlue,3))
-pow(epsilon_gamma,2)+5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}