import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "pow(\\([^)]+),2\\)";
final String string = "pow(alpha,2) + pow(beta,2)\n"
+ "(3*pow(betaR_red,2))\n"
+ "2/pow(gammaBlue,3))\n"
+ "-pow(epsilon_gamma,2)+5";
final String subst = "square\\1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}