use strict;
my $str = 'pow(alpha,2) + pow(beta,2)
(3*pow(betaR_red,2))
2/pow(gammaBlue,3))
-pow(epsilon_gamma,2)+5';
my $regex = qr/pow(\([^)]+),2\)/mp;
my $subst = 'square\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";