import re
regex = re.compile(r"pow(\([^)]+),2\)", flags=re.MULTILINE)
test_str = ("pow(alpha,2) + pow(beta,2)\n"
"(3*pow(betaR_red,2))\n"
"2/pow(gammaBlue,3))\n"
"-pow(epsilon_gamma,2)+5")
subst = "square\\1)"
result = regex.sub(subst, test_str)
if result:
print(result)