using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^']*'(*SKIP)(*F)|""";
string substitution = @"'";
string input = @"""foo""
=> 'foo'
'foo'
=> 'foo'
abc ""foo""
=> abc 'foo'
foo ""bar"", ""baz""
=> foo 'bar', 'baz'
abc 'foo ""bar"" baz'
=> abc 'foo ""bar"" baz'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}