import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'[^']*'(*SKIP)(*F)|\"";
final String string = "\"foo\"\n"
+ " => 'foo'\n"
+ "'foo'\n"
+ " => 'foo'\n"
+ "abc \"foo\"\n"
+ " => abc 'foo'\n"
+ "foo \"bar\", \"baz\"\n"
+ " => foo 'bar', 'baz'\n"
+ "abc 'foo \"bar\" baz'\n"
+ " => abc 'foo \"bar\" baz'";
final String subst = "'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}