package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'[^']*'(*SKIP)(*F)|"`)
var str = `"foo"
=> 'foo'
'foo'
=> 'foo'
abc "foo"
=> abc 'foo'
foo "bar", "baz"
=> foo 'bar', 'baz'
abc 'foo "bar" baz'
=> abc 'foo "bar" baz'`
var substitution = "'"
fmt.Println(re.ReplaceAllString(str, substitution))
}