$re = '/\'[^\']*\'(*SKIP)(*F)|"/';
$str = '"foo"
=> \'foo\'
\'foo\'
=> \'foo\'
abc "foo"
=> abc \'foo\'
foo "bar", "baz"
=> foo \'bar\', \'baz\'
abc \'foo "bar" baz\'
=> abc \'foo "bar" baz\'';
$subst = "'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;