# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Price\d+)/COALESCE(\1, 0)/g;t' <<< "Price1
Price2
Price3"