use strict;
my $str = 'Price1
Price2
Price3';
my $regex = qr/(Price\d+)/p;
my $subst = 'COALESCE(\\1, 0)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";