$re = '/(Price\d+)/';
$str = 'Price1
Price2
Price3';
$subst = "COALESCE(\1, 0)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;