const regex = /(Price\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Price\\d+)', 'g')
const str = `Price1
Price2
Price3`;
const subst = `COALESCE(\1, 0)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);