using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Price\d+)";
string substitution = @"COALESCE(\1, 0)";
string input = @"Price1
Price2
Price3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}