re = /(Price\d+)/
str = 'Price1
Price2
Price3'
subst = 'COALESCE(\\1, 0)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result