#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(Price\d+)"
Local $sString = "Price1" & @CRLF & _
"Price2" & @CRLF & _
"Price3"
Local $sSubst = "COALESCE(\1, 0)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)