// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Price\d+)").unwrap();
let string = "Price1
Price2
Price3";
let substitution = "COALESCE(\\1, 0)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}