# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)|(\*.*)/#\2/gm;t' <<< "hello23 the2e are 13 5.12apples *specially_x00123 named"