re = /(\d)|(\*.*)/m
str = 'hello23 the2e are 13 5.12apples *specially_x00123 named'
subst = '#\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result