const regex = new RegExp('(\\d)|(\\*.*)', 'gm')
const str = `hello23 the2e are 13 5.12apples *specially_x00123 named`;
const subst = `#\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);