import re
regex = re.compile(r"(\d)|(\*.*)", flags=re.MULTILINE)
test_str = "hello23 the2e are 13 5.12apples *specially_x00123 named"
subst = "#\\2"
result = regex.sub(subst, test_str)
if result:
print(result)