import Foundation
let pattern = #"(\d)|(\*.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"hello23 the2e are 13 5.12apples *specially_x00123 named"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#\2"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)