#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\"SocRole\\":\s\\"([^\\]+)|\\"PermissionGroup\\":\s\\"([^\\]+)"
Local $sString = "\"Email\": \"testesiem@gmail.com\"," & @CRLF & _
"\"Environments\": [" & @CRLF & _
"\"*\"" & @CRLF & _
"]," & @CRLF & _
"\"LicenseType\": \"Regular\"," & @CRLF & _
"\"PermissionGroup\": \"Admins\"," & @CRLF & _
"\"SocRole\": \"Administrator\"," & @CRLF & _
"\"UserType\": \"External\"" & @CRLF & _
"}"" & @CRLF & _
"\"Email\": \"AymanC@gmail.com\"," & @CRLF & _
"\"Environments\": [" & @CRLF & _
"\"*\"" & @CRLF & _
"]," & @CRLF & _
"\"LicenseType\": \"Regular\"," & @CRLF & _
"\"PermissionGroup\": \"Admins\"," & @CRLF & _
"\"SocRole\": \"Administrator\"," & @CRLF & _
"\"UserType\": \"External\"" & @CRLF & _
"}"" & @CRLF & _
"\"Email\": \"Aym4nn@gmail.com\"," & @CRLF & _
"\"Environments\": [" & @CRLF & _
"\"*\"" & @CRLF & _
"]," & @CRLF & _
"\"LicenseType\": \"Regular\"," & @CRLF & _
"\"PermissionGroup\": \"Admins\"," & @CRLF & _
"\"SocRole\": \"Administrator\"," & @CRLF & _
"\"UserType\": \"External\"" & @CRLF & _
"}""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")