using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\""SocRole\\"":\s\\""([^\\]+)|\\""PermissionGroup\\"":\s\\""([^\\]+)";
string input = @"\""Email\"": \""testesiem@gmail.com\"",
\""Environments\"": [
\""*\""
],
\""LicenseType\"": \""Regular\"",
\""PermissionGroup\"": \""Admins\"",
\""SocRole\"": \""Administrator\"",
\""UserType\"": \""External\""
}""
\""Email\"": \""AymanC@gmail.com\"",
\""Environments\"": [
\""*\""
],
\""LicenseType\"": \""Regular\"",
\""PermissionGroup\"": \""Admins\"",
\""SocRole\"": \""Administrator\"",
\""UserType\"": \""External\""
}""
\""Email\"": \""Aym4nn@gmail.com\"",
\""Environments\"": [
\""*\""
],
\""LicenseType\"": \""Regular\"",
\""PermissionGroup\"": \""Admins\"",
\""SocRole\"": \""Administrator\"",
\""UserType\"": \""External\""
}""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}