const regex = /\\"SocRole\\":\s\\"([^\\]+)|\\"PermissionGroup\\":\s\\"([^\\]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\"SocRole\\\\":\\s\\\\"([^\\\\]+)|\\\\"PermissionGroup\\\\":\\s\\\\"([^\\\\]+)', 'gm')
const str = `\\"Email\\": \\"testesiem@gmail.com\\",
\\"Environments\\": [
\\"*\\"
],
\\"LicenseType\\": \\"Regular\\",
\\"PermissionGroup\\": \\"Admins\\",
\\"SocRole\\": \\"Administrator\\",
\\"UserType\\": \\"External\\"
}"
\\"Email\\": \\"AymanC@gmail.com\\",
\\"Environments\\": [
\\"*\\"
],
\\"LicenseType\\": \\"Regular\\",
\\"PermissionGroup\\": \\"Admins\\",
\\"SocRole\\": \\"Administrator\\",
\\"UserType\\": \\"External\\"
}"
\\"Email\\": \\"Aym4nn@gmail.com\\",
\\"Environments\\": [
\\"*\\"
],
\\"LicenseType\\": \\"Regular\\",
\\"PermissionGroup\\": \\"Admins\\",
\\"SocRole\\": \\"Administrator\\",
\\"UserType\\": \\"External\\"
}"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}