import Foundation
let pattern = #"\\"SocRole\\":\s\\"([^\\]+)|\\"PermissionGroup\\":\s\\"([^\\]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\"Email\": \"testesiem@gmail.com\",
\"Environments\": [
\"*\"
],
\"LicenseType\": \"Regular\",
\"PermissionGroup\": \"Admins\",
\"SocRole\": \"Administrator\",
\"UserType\": \"External\"
}"
\"Email\": \"AymanC@gmail.com\",
\"Environments\": [
\"*\"
],
\"LicenseType\": \"Regular\",
\"PermissionGroup\": \"Admins\",
\"SocRole\": \"Administrator\",
\"UserType\": \"External\"
}"
\"Email\": \"Aym4nn@gmail.com\",
\"Environments\": [
\"*\"
],
\"LicenseType\": \"Regular\",
\"PermissionGroup\": \"Admins\",
\"SocRole\": \"Administrator\",
\"UserType\": \"External\"
}"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)