package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\"SocRole\\":\s\\"([^\\]+)|\\"PermissionGroup\\":\s\\"([^\\]+)`)
var str = `\"Email\": \"testesiem@gmail.com\",
\"Environments\": [
\"*\"
],
\"LicenseType\": \"Regular\",
\"PermissionGroup\": \"Admins\",
\"SocRole\": \"Administrator\",
\"UserType\": \"External\"
}"
\"Email\": \"AymanC@gmail.com\",
\"Environments\": [
\"*\"
],
\"LicenseType\": \"Regular\",
\"PermissionGroup\": \"Admins\",
\"SocRole\": \"Administrator\",
\"UserType\": \"External\"
}"
\"Email\": \"Aym4nn@gmail.com\",
\"Environments\": [
\"*\"
],
\"LicenseType\": \"Regular\",
\"PermissionGroup\": \"Admins\",
\"SocRole\": \"Administrator\",
\"UserType\": \"External\"
}"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}