import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\\"SocRole\\\\\":\\s\\\\\"([^\\\\]+)|\\\\\"PermissionGroup\\\\\":\\s\\\\\"([^\\\\]+)";
final String string = "\\\"Email\\\": \\\"testesiem@gmail.com\\\",\n"
+ "\\\"Environments\\\": [\n"
+ "\\\"*\\\"\n"
+ "],\n"
+ "\\\"LicenseType\\\": \\\"Regular\\\",\n"
+ "\\\"PermissionGroup\\\": \\\"Admins\\\",\n"
+ "\\\"SocRole\\\": \\\"Administrator\\\",\n"
+ "\\\"UserType\\\": \\\"External\\\"\n"
+ "}\"\n"
+ "\\\"Email\\\": \\\"AymanC@gmail.com\\\",\n"
+ "\\\"Environments\\\": [\n"
+ "\\\"*\\\"\n"
+ "],\n"
+ "\\\"LicenseType\\\": \\\"Regular\\\",\n"
+ "\\\"PermissionGroup\\\": \\\"Admins\\\",\n"
+ "\\\"SocRole\\\": \\\"Administrator\\\",\n"
+ "\\\"UserType\\\": \\\"External\\\"\n"
+ "}\"\n"
+ "\\\"Email\\\": \\\"Aym4nn@gmail.com\\\",\n"
+ "\\\"Environments\\\": [\n"
+ "\\\"*\\\"\n"
+ "],\n"
+ "\\\"LicenseType\\\": \\\"Regular\\\",\n"
+ "\\\"PermissionGroup\\\": \\\"Admins\\\",\n"
+ "\\\"SocRole\\\": \\\"Administrator\\\",\n"
+ "\\\"UserType\\\": \\\"External\\\"\n"
+ "}\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}