re = /\\"SocRole\\":\s\\"([^\\]+)|\\"PermissionGroup\\":\s\\"([^\\]+)/m
str = '\\"Email\\": \\"testesiem@gmail.com\\",
\\"Environments\\": [
\\"*\\"
],
\\"LicenseType\\": \\"Regular\\",
\\"PermissionGroup\\": \\"Admins\\",
\\"SocRole\\": \\"Administrator\\",
\\"UserType\\": \\"External\\"
}"
\\"Email\\": \\"AymanC@gmail.com\\",
\\"Environments\\": [
\\"*\\"
],
\\"LicenseType\\": \\"Regular\\",
\\"PermissionGroup\\": \\"Admins\\",
\\"SocRole\\": \\"Administrator\\",
\\"UserType\\": \\"External\\"
}"
\\"Email\\": \\"Aym4nn@gmail.com\\",
\\"Environments\\": [
\\"*\\"
],
\\"LicenseType\\": \\"Regular\\",
\\"PermissionGroup\\": \\"Admins\\",
\\"SocRole\\": \\"Administrator\\",
\\"UserType\\": \\"External\\"
}"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end