// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\\"SocRole\\":\s\\"([^\\]+)|\\"PermissionGroup\\":\s\\"([^\\]+)"#).unwrap();
let string = "\\\"Email\\\": \\\"testesiem@gmail.com\\\",
\\\"Environments\\\": [
\\\"*\\\"
],
\\\"LicenseType\\\": \\\"Regular\\\",
\\\"PermissionGroup\\\": \\\"Admins\\\",
\\\"SocRole\\\": \\\"Administrator\\\",
\\\"UserType\\\": \\\"External\\\"
}\"
\\\"Email\\\": \\\"AymanC@gmail.com\\\",
\\\"Environments\\\": [
\\\"*\\\"
],
\\\"LicenseType\\\": \\\"Regular\\\",
\\\"PermissionGroup\\\": \\\"Admins\\\",
\\\"SocRole\\\": \\\"Administrator\\\",
\\\"UserType\\\": \\\"External\\\"
}\"
\\\"Email\\\": \\\"Aym4nn@gmail.com\\\",
\\\"Environments\\\": [
\\\"*\\\"
],
\\\"LicenseType\\\": \\\"Regular\\\",
\\\"PermissionGroup\\\": \\\"Admins\\\",
\\\"SocRole\\\": \\\"Administrator\\\",
\\\"UserType\\\": \\\"External\\\"
}\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}