using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(# .+?\\n)(.+)";
string substitution = @"\1";
string input = @"# Title\n## Chapter\n### sub-chapter#### The Bar\nIt was a fall day.\n";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}