const regex = new RegExp('(# .+?\\\\n)(.+)', '')
const str = `# Title\\n## Chapter\\n### sub-chapter#### The Bar\\nIt was a fall day.\\n`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);