import re
regex = re.compile(r"(# .+?\\n)(.+)")
test_str = "# Title\\n## Chapter\\n### sub-chapter#### The Bar\\nIt was a fall day.\\n"
subst = "\\1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)