// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(# .+?\\n)(.+)").unwrap();
let string = "# Title\\n## Chapter\\n### sub-chapter#### The Bar\\nIt was a fall day.\\n";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}