$re = '/(# .+?\\\\n)(.+)/';
$str = '# Title\\n## Chapter\\n### sub-chapter#### The Bar\\nIt was a fall day.\\n';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;