# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ASP\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\s*//g;t' <<< "PortalAlias=Portal; Language_PostPortal=en-US; ASP.NET_SessionId=opn4y4n1qja0mtzm4sx4514'or+1=1--; portalroles=50FA411EBBAC79"