const regex = /ASP\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ASP\\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\\s*', 'g')
const str = `PortalAlias=Portal; Language_PostPortal=en-US; ASP.NET_SessionId=opn4y4n1qja0mtzm4sx4514'or+1=1--; portalroles=50FA411EBBAC79`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);