re = /ASP\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\s*/
str = 'PortalAlias=Portal; Language_PostPortal=en-US; ASP.NET_SessionId=opn4y4n1qja0mtzm4sx4514\'or+1=1--; portalroles=50FA411EBBAC79'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result