use strict;
my $str = 'PortalAlias=Portal; Language_PostPortal=en-US; ASP.NET_SessionId=opn4y4n1qja0mtzm4sx4514\'or+1=1--; portalroles=50FA411EBBAC79';
my $regex = qr/ASP\.NET_SessionId=[a-z0-9]*[^a-z0-9;][^;]*;\s*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";