# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^.]*\.([^\\/]*)\\/.*?\\/({.*?})\\/(#.*)$/http:\/\/$2.$1\/$3/gm;t' <<< "http://www.domain.de/specific-folder/{data}/#link"