using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$";
string substitution = @"http://$2.$1/$3";
string input = @"http://www.domain.de/specific-folder/{data}/#link";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}