package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$`)
var str = `http://www.domain.de/specific-folder/{data}/#link`
var substitution = "http://$2.$1/$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}