const regex = /^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^.]*\\.([^\\\/]*)\\\/.*?\\\/({.*?})\\\/(#.*)$', 'gm')
const str = `http://www.domain.de/specific-folder/{data}/#link`;
const subst = `http://$2.$1/$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);