$re = '/^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$/m';
$str = 'http://www.domain.de/specific-folder/{data}/#link';
$subst = "http://$2.$1/$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;