#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$"
Local $sString = "http://www.domain.de/specific-folder/{data}/#link"
Local $sSubst = "http://$2.$1/$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)