import Foundation
let pattern = ##"^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"http://www.domain.de/specific-folder/{data}/#link"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://$2.$1/$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)