use strict;
my $str = 'http://www.domain.de/specific-folder/{data}/#link';
my $regex = qr/^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$/mp;
my $subst = 'http://$2.$1/$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";