re = /^[^.]*\.([^\/]*)\/.*?\/({.*?})\/(#.*)$/m
str = 'http://www.domain.de/specific-folder/{data}/#link'
subst = 'http://$2.$1/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result