# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:y\b/a/gm;t' <<< "Good one :y. Keep going :y2
"