// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):y\b").unwrap();
let string = "Good one :y. Keep going :y2
";
let substitution = "a";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}